задание для исполнителя "черепашка".

Восстановите результат работы алгоритма.

Восстановить результат работы алгоритма 

алг задача4

нач

¦ закрасить

¦ нц 8 раз

¦ ¦ вниз

¦ ¦ закрасить

¦ кц

¦ нц 4 раз

¦ ¦ влево

¦ кц

¦ нц 4 раз

¦ ¦ вверх

¦ кц

¦ нц 4 раз

¦ ¦ закрасить

¦ ¦ вправо

¦ кц

¦ вправо

¦ нц 4 раз

¦ ¦ закрасить

¦ ¦ вправо

¦ кц

кон

 

Восстановить результат работы алгоритма

алг задача2

нач

¦ нц 5 раз

¦ ¦ вниз

¦ ¦ закрасить

¦ кц

¦ нц 4 раз

¦ ¦ вправо

¦ ¦ закрасить

¦ кц

¦ нц 4 раз

¦ ¦ вверх

¦ ¦ закрасить

¦ кц

¦ нц 4 раз

¦ ¦ вправо

¦ ¦ закрасить

¦ кц

¦ нц 4 раз

¦ ¦ вниз

¦ ¦ закрасить

¦ кц

кон

Восстановить результат работы алгоритма

алг задача8

нач

¦ нц 5 раз

¦ ¦ вниз

¦ ¦ вправо

¦ ¦ закрасить

¦ кц

¦ нц 4 раз

¦ ¦ влево

¦ кц

¦ нц 2 раз

¦ ¦ закрасить

¦ ¦ вверх

¦ ¦ вправо

¦ кц

¦ нц 2 раз

¦ ¦ вправо

¦ ¦ вверх

¦ ¦ закрасить

¦ кц

кон

Восстановить результат работы алгоритма

алг задача6

нач

¦ нц 5 раз

¦ ¦ вправо

¦ ¦ закрасить

¦ кц

¦ вправо

¦ вверх

¦ нц 5 раз

¦ ¦ влево

¦ ¦ закрасить

¦ кц

¦ влево

¦ вверх

¦ нц 5 раз

¦ ¦ вправо

¦ ¦ закрасить

¦ кц

¦ вправо

¦ вверх

¦ нц 3 раз

¦ ¦ влево

¦ ¦ закрасить

¦ ¦ влево

¦ кц

кон

Восстановить результат работы алгоритма

алг задача7

нач

¦ нц 5 раз

¦ ¦ вниз

¦ ¦ закрасить

¦ ¦ вправо

¦ кц

¦ влево

¦ влево

¦ нц 7 раз

¦ ¦ закрасить

¦ ¦ влево

¦ кц

¦ нц 4 раз

¦ ¦ закрасить

¦ ¦ вверх

¦ ¦ вправо

¦ кц

кон

Восстановить результат работы алгоритма

алг задача5

нач

¦ нц 5 раз

¦ ¦ закрасить

¦ ¦ вверх

¦ кц

¦ нц 3 раз

¦ ¦ закрасить

¦ ¦ вправо

¦ кц

¦ нц 3 раз

¦ ¦ закрасить

¦ ¦ вниз

¦ кц

¦ нц 2 раз

¦ ¦ закрасить

¦ ¦ влево

¦ кц

¦ закрасить

кон

Восстановить результат работы алгоритма

алг задача9

нач

¦ нц 4 раз

¦ ¦ вправо

¦ ¦ закрасить

¦ кц

¦ нц 3 раз

¦ ¦ вниз

¦ ¦ закрасить

¦ кц

¦ нц 3 раз

¦ ¦ вправо

¦ ¦ закрасить

¦ кц

¦ нц 3 раз

¦ ¦ вниз

¦ ¦ закрасить

¦ кц

кон

Восстановить результат работы алгоритма

алг задача10

нач

¦ нц 3 раз

¦ ¦ вправо

¦ ¦ закрасить

¦ кц

¦ вверх

¦ влево

¦ нц 3 раз

¦ ¦ закрасить

¦ ¦ вверх

¦ кц

¦ влево

¦ нц 3 раз

¦ ¦ закрасить

¦ ¦ вправо

¦ кц

кон

Восстановить результат работы алгоритма

алг задача3

нач

¦ нц 3 раз

¦ ¦ вправо

¦ ¦ закрасить

¦ ¦ вправо

¦ ¦ вверх

¦ ¦ закрасить

¦ ¦ вниз

¦ ¦ вниз

¦ ¦ закрасить

¦ ¦ вправо

¦ ¦ вверх

¦ ¦ закрасить

¦ ¦ вправо

¦ кц

       кон

Восстановить результат работы алгоритма

алг задача1

нач

¦ нц 2 раз

¦ ¦ вверх

¦ ¦ закрасить

¦ ¦ вправо

¦ ¦ закрасить

¦ ¦ вправо

¦ ¦ вниз

¦ ¦ вправо

¦ ¦ закрасить

¦ ¦ вправо

¦ ¦ закрасить

¦ ¦ вправо

¦ ¦ вправо

¦ кц

кон

Восстановить результат работы алгоритма

алг задача11

нач

¦ нц 5 раз

¦ ¦ вверх

¦ ¦ вверх

¦ ¦ вправо

¦ ¦ закрасить

¦ ¦ вниз

¦ ¦ закрасить

¦ ¦ вниз

¦ ¦ закрасить

¦ ¦ вправо

¦ ¦ закрасить

¦ кц

кон

Восстановить результат работы алгоритма

алг задача12

нач

¦ нц 5 раз

¦ ¦ вправо

¦ ¦ закрасить

¦ кц

¦ нц 4 раз

¦ ¦ вверх

¦ ¦ закрасить

¦ кц

¦ нц 3 раз

¦ ¦ вниз

¦ ¦ влево

¦ ¦ закрасить

¦ кц

кон

 

 

 

Контакт

Телефон: 28-39-12

Адрес: г. Саратов ул. Мичурина 88